Synology порты служб cloud-script.ru

Synology порты служб

Настройкa DDNS

Поддержка DDNS в сетевых накопителях Synology

Сетевые накопители Synology обладают одной из самых развитых систем поддержки DDNS. Системное управляющее ПО Synology Disk Station Manager включает в себя службу DDNS, которая позволяет пользователю выбрать оптимального для себя DDNS провайдера из списка заранее заданных производителем NAS. Список постепенно расширяется по мере сертификации DDNS провайдеров на совместимость со встроенным ПО Synology DSM.

Как начать использовать DDNS?
1) Вам необходимо зарегистрироваться на сайте провайдера DDNS-услуг. Как правило это совершенно бесплатно. Одним из самых популярных DDNS-провайдеров является dyndns.org

2) Войти с созданным логином и паролем в свой аккаунт на сайте DDNS-провайдера и выбрать пункт «Add host service» (добавить хост-службу).

3) В открывшемся окне вам необходимо выбрать желаемое имя для своего домена третьего уровня в любой из предложенных DDNS-провайдером доменных зон. Обычно провайдеры DDNS предлагают достаточо широкий список DDNS -доменов — остальное зависит от вашей фантазии или конкретных задач.

Как правило при подключении сайт DDNS-провайдера автоматически определит ваш текущий IP-адрес и будет в дальнейшем отслеживать его изменения, происходящее в результате циклического перераспределения внутренней номерной емкости IP-адресов вашего домашнего или офисного интернет-провайдера. В случае если автоматическое определение не произошло, вы можете нажать на ссылку «Use auto detect IP address» (использовать автоматическое определение IP-адреса). Нажмите кнопку завершения регистрации DDNS-домена для сохранения вашей регистрационной информации.

4) Теперь вы можете приступать к подключению DDNS-службы в своем сетевом накопителе Synology. Для этого вам потребуется войти в управляющем меню Synology DSM в службу DDNS и активировать ее, поставив галочку в соответствующем поле: «Включить функцию DDNS Support».
Далее, в настройках службы DDNS Synology DSM укажите выбранного DDNS-провайдера, ваш логин, пароль и придуманное вам доменное имя третьего уровня. В нашем случае мы указали synodemo.dydns.org

Примерно через 24 часа ваш домен будет активирован. Подтверждением, того что DDNS-адресация успешно заработала будет свидетельствовать сообщение службы DDNS в NAS Synology, согласно которому будет отображена информация о подключении к DDNS-провайдеру с состоянием «Нормальный» и полной информацией о внешнем и внутреннем IP-адресе в поле «Информация о шлюзе».

Дополнительные требования
Взаимодействие DDNS-службы NAS Synology c DDNS провайдером по умолчанию происходит через логический порт TCP № 5000 для протокола HTTP и № 5001 для протокола HTTPs. FTP стандартно подключается через логический порт № 21.
Для успешного подключения службы DDNS в NAS Synology к DDNS-провайдеру необходимо, чтобы указанные логические TCP порты были разрешены к использованию («открыты») на вашем роутере. Обычно логических портов находятся в роутерах в разделе Port Forwarding или Virtual Server.
Рассмотрим типичные настройки Virtual Server одного из популярных роутеров.


На иллюстрации мы видим следующие параметры настроек:
Name: любое удобное вам название для сервиса доступа (для его идентификации)
Private IP: в данном случае это адрес нашего сетевого накопителя Synology (192.168.0.126), полученный от роутера по DHCP или прописанный пользователем в ручную.
Protocol: Тип протокола и номер логического порта по которому происходит доступ извне сети и внутри сети (эти порты для внутреннего и внешнего доступа могут отличаться, но мы их для простоты делаем одинаковыми).
Schedule: расписание доступности сервиса доступа. По вашему желанию вы можете задавать временные интервалы когда сервис включен и когда выключен. В нашем случае мы выбрали опцию «Always», что означает постоянную активность сервиса.
В рассмотренном примере у нас открыты следующие порты:

Доступ к NAS-устройству Synology и обмен файлами через интернет

Если вам необходимо сделать некоторую часть своих файлов доступной через интернет друзьям и коллегам, хорошим решением станет Synology NAS. Файловое хранилище может выступать в роли FTP-сервера. И вы сможете определить, кому и к каким файлам и папкам предоставить доступ.

Вторая возможность — WebDAV. Этот сервис является расширением протокола HTTP и дает возможность редактирования файлов на удаленных серверах и управления ими. С точки зрения пользователя все будет выглядеть так, как если бы контент располагался на их компьютерах. Обращаться к содержимому удаленного сервера они смогут с использованием файлового менеджера. В их числе Finder (macOS), File Browser (Linux) и целый ряд приложений этой категории для Windows.

Третья возможность — обо всем позаботится служба QuickConnect. Необходимо будет лишь создать аккаунт Synology и появится ссылка, которая в дальнейшем станет применяться для доступа к хранилищу файлов. Это сильно упрощает обмен файлами с другими пользователями, поскольку заботиться о переадресации порта вам не придется. Но обо всем по порядку.

Ранее я уже делал распаковку и первый запуск устройства Synology DS218 с дисками Seagate IronWolf 8 Тб. Рассказывал почему сделал выбор именно в пользу данных производителей.

Также, пользователям OS X от Apple, рекомендую прочесть другую статью, посвященную настройке резервного копирования Time Machine на файловое хранилище по сети.

А сегодня хочу рассказать о самом простом способе доступа к NAS-устройству Synology через интернет и обмен файлами.

Служба QuickConnect

С помощью службы QuickConnect вы легко подключитесь к вашему NAS-устройству Synology через интернет, не имея никаких навыков администрирования сети. То есть с этой процедурой справится любой пользователь, нужно всего лишь следовать пошаговым указаниям в данной статье.

В первую очередь нужно обновить DSM до последней версии. В моем случае это DSM 6.2.2-24922 Update 2:

Далее нужно настроить QuickConnect. Через данную службу можно подключиться с помощью короткой ссылки, в моем случае – Quickconnect.to/poznyaev. Вместо «poznyaev» вы зададите свое слово или будете использовать любой набор символов.

После обновления переходите в «Панель управления» – «QuickConnect».
Установите галочку «Включить QuickConnect» и согласитесь с «условиями использования» и «политикой конфиденциальности».
И, наконец, кликните «Вход или регистрация учетной записи Synology»:

Если вы не создавали учетную запись во время первого запуска Synology, нажмите «Создать учетную запись». Если учетная запись имеется, введите адрес электронной почты и пароль, после чего кликните «Вход»:

В поле «QuickConnect ID» создайте уникальный идентификатор. Нажмите «Применить»:

Читать еще:  Включение hyper v в Windows 10

Через некоторое время появится ссылка на QuickConnect. Чтобы подключиться к вашему файловому хранилищу, нужно в браузере ввести эту ссылку, в моем случае – это http://QuickConnect.to/poznyaev.

Важно . Если ссылка на QuickConnect DSM не появилась, нужно перейти в «Дополнительно» и проверить наличие галочки напротив «DSM». Также установите галочку «Обмен файлами», это даст возможность делиться файлами на вашем NAS по прямой ссылке, об этом ниже.

После проделанных настроек вы можете подключаться к вашему NAS с любого компьютера или мобильного устройства, используя браузер.

Обмен файлами на файловом хранилище с помощью службы QuickConnect

После включения службы QuickConnect вы можете передавать свои файлы, которые хранятся на вашем NAS, кому угодно, по аналогии с облачными хранилищами.

Для безопасного обмена информацией, нужно включить соединение HTTPS. Переходите в «Панель управления» – «Сеть» – «Настройки DSM».
Ставьте галочки «Автоматически перенаправлять подключения …» и «Включить HTTP/2», не забудьте нажать «Применить». После применения вас перенаправит на безопасный протокол HTTPS:

Примечание
При настройке дополнительных параметров QuickConnect рекомендуется войти в DSM, используя локальный IP-адрес или доменное имя устройства NAS Synology.

Функцию обмена файлами для QuickConnect мы уже включили ранее, поэтому теперь готовы начать обмен файлами с помощью QuickConnect. Откройте «File Station» и щелкните правой кнопкой мыши на файле или папке, чтобы предоставить общий доступ к ним. Затем в контекстном меню выберите «Использовать совместно»:

Откроется окно со ссылкой общего доступа. Перешлите ее человеку, которому предназначаются эти данные:

Если нужно ограничить время действия ссылки, сделать это можно, кликнув по кнопке «Срок действия»:

  • Общий доступ с пользователями DSM.
  • Общий доступ с другими.

После перехода по ссылке, откроется такое окно:

Synology NAS сделает работу с файлами через интернет не менее удобной, чем с теми, которые расположены на жестком диске компьютера. Подобная возможность может оказаться очень полезной при совместной работе над проектами или наличии определенного объема информации, к которой нужно иметь возможность обратиться с любого компьютера и из любого места, где есть доступ к интернету.

Настроив соответствующим образом свой ноутбук, вы сможете быть уверены, что ваша мультимедийная коллекция всегда под рукой, где бы вы ни находились. И расстояние от дисплея до накопителя перестает играть какую-либо роль в доступности той информации, которая нужна вам в данную минуту.

Авторизуясь, вы даете согласие на обработку персональных данных.

Настройка LACP (Bond) на NAS Synology

Настройка LACP (Bond) на NAS Synology

Добрый день! Уважаемые читатели и гости одного из крупнейших блогов по системному администрированию Pyatilistnik.org. В прошлый раз мы с вами разобрали базовую настройку роутера Mikrotik, организовав работу небольшого офиса. В сегодняшней публикации я с вами хочу поделиться информацией, как производится настройка агрегирования сетевых интерфейсов на NAS Synology RS2414+, мы поговорим, какие виды LACP есть у Synology, что лучше выбрать, может быть данная информация будет кому-то полезной.

Виды LACP на оборудовании Synology

И так, есть у меня NAS RS2414+, в котором 12 дисков. Сзади оборудования есть 4-ре сетевых интерфейсов по 1 гигабайту. Чтобы сделать оборудование более пропускным и отказоустойчивым, делают объединение сетевых интерфейсов в общий пул, такое вы проделывали в Csico настраивая LACP.

У Synology вместо понятия LACP вводится Bond, это отсылка к Bonding на Linux (https://ru.wikipedia.org/wiki/Агрегирование_каналов). Так как у меня 4 сетевых интерфейса, то их можно объединять в такие пулы, например первые два под сеть управления, третий и четвертый для подключения по ISCSI. Ниже мы разберем данную реализацию.

  1. Adaptive Load Balancing (Адаптивная балансировка нагрузки): это самая простая настройка и не требует специального оборудования. Можно использовать любой сетевой коммутатор, даже коммутаторы начального уровня, у которого может даже не быть настройки LACP. Вы также можете подключить каждый порт к разным коммутаторам, чтобы обеспечить некоторую избыточность. В данном режиме работает алгоритм по оптимизации сетевого трафика, который принимает и отправляет ваш NAS Synology, обычно при данном режиме на стороне коммутатора вообще не создают PortChannel или LACP.
  2. IEEE 802.3ad Dynamic Link Aggregation: это более сложный и более дорогой в настройке. Вам понадобится коммутатор, который поддерживает 802.3ad LACP (LACP, 802.1AX), данный динамический режим должен быть обязательно включен. Хотя может быть исключение, я не видел переключателей уровня потребителя, которые поддерживают это.
  3. Balance XOR: это более ранняя версия стандарта 802.3ad v1, которая называется Static Link Aggregation. Это наиболее сложная настройка, по крайней мере, потенциально. Вы должны настроить DSM и коммутатор. Что делает его потенциально более сложным. Кроме того, если порт или кабель коммутатора выходит из строя, DSM или клиентское программное обеспечение могут не переключиться и будут продолжать пытаться использовать плохое соединение. LACP также выполняет более эффективную работу по балансировке соединений между портами. Если это вообще возможно, используйте LACP вместо статической конфигурации.
  4. Active/Standby (Активный/Ожидание): обеспечивает только отказоустойчивость (network fault tolerance). Никакого специального оборудования не требуется, и можно использовать разные коммутаторы. Тут если выходит из строя активный адаптер, у вас автоматически идет переключение на запасной.

Настройка Bond на Synology

  • Заходим в веб интерфейс управления вашим NAS, открываем «Control Panel» и выбираем «Network«.

  • Открываем вкладку «Network Interface» и нажимаем на «Create Bond (LACP)».

/wp-content/uploads/2019/07/synology-bond-02.jpg»>

  • У вас появится окно «Link Aggregation Mode» благодаря которому вы и реализуете балансировку и отказоустойчивость интерфейсов. Про виды я писал выше, я выбираю «IEEE 802.3ad Dynamic Link Aggregation», так как мой коммутатор поддерживает стандарт.

  • Далее указываем какие сетевые интерфейсы вы будите объединять в Bond, в моем примере, это LAN1 и LAN2.

Далее вы можете либо по DHCP получить сетевые настройки, либо как и я по старинке сделать статический IP-адрес, задав маску и шлюз с DNS сервером, обратите внимание что вы можете задать размер MTU и включить нужный VLAN если у вас тегированный трафик, через транк порт. Нажимаем Apply и создаем наш объединенный канал Bond.

Читать еще:  Security log agent что это за программа?

В итоге у меня появился Bond 1, состоящий из двух сетевых интерфейсов и имеющих один ip-адрес.

Когда у вас создан Bond вы всегда легко можете изменить настройки через кнопку «Edit«, на первом окне у вас появится окно с выбором типа LACP.

На вкладках IPv4 и IPv6 вы легко поменяете адрес, шлюз или другие сетевые настройки.

Вкладка 802.1X позволит настроить аутентификацию.

Как настроить несколько VLAN на одном Bond Synology

Бывают ситуации, что вы хотите разделить вашу сеть на отдельные сегменты, например одну для пользователей, вторую для администраторов или серверов. Для таких вещей есть VLAN, все верно, но есть пожелание, делать это не за счет отдельных сетевых интерфейсов, а воспользоваться уже существующем Bond в Linux такая вещь делалась на ура и Synology вас так же порадует. Первое, что нужно сделать, это включить в настройках сетевого интерфейса или LACP опцию «Enable VLAN»

Далее вам необходимо подключиться по ssh и sftp к вашему NAS Synology, я для этого использую mRemoteNG или WinSCP. переходите там в расположение /etc/sysconfig/network-scripts/. В приведенном ниже примере вы увидите, что у моей Synology есть связь, использующая eth0 и eth1. В моей настройке требовалось установить дополнительные интерфейсы с метками VLAN поверх моего физического интерфейса связи. Как видите, у меня есть подчиненный интерфейс для VLAN 100, 120, 130 и 20. Вам нужно только скопировать файл конфигурации, используя формат именования ifcfg-

. , и настроить его по вашим потребностям.

(Скопированный) файл конфигурации выглядит следующим образом:

DEVICE=bond0.2
VLAN_ROW_DEVICE=bond0
VLAN_ID=100
ONBOOT=yes
BOOTPROTO=static
IPADDR=192.168.100.37
NETMASK=255.255.255.0
IPV6INIT=auto_dhcp
IPV6_ACCEPT_RA=1
DEVICE VLAN_ID IPADDR

Synology порты служб

Настройка оборудования MikroTik

Резервирование, агрегация, VPN, скрипты для решения нестандартных задач.

Помогите пробросить 80 порт к веб-серверу на Synology

Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку «Действия до настройки роутера».
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там /export hide-sensitive. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.

Всем здравствуйте!
Сразу оговорюсь:
1. Микротик использую впервые.
2. Знания об устройстве сети — самые начальные.
3. Форум и другие ресурсы гуглил.

Что есть (распишу подробно):
1. Интернет от Онлайм (DHCP), IP белый динамический.
2. Дальше стоит свитч, к которому приходит кабель от интернет-розетки, от него провода: к роутеру и PS4 (чтобы на ней был NAT1).
3. Роутер Mikrotik hap ac, RouterOS 6.37(начальная конфигурация по умолчанию).
4. К роутеру подключены проводами:
ether1 — wan (кабель от свитча)
ether2-master — NAS Synology DS713+ (DSM 6) — IP Static 192.168.88.150
ether3 — TV Samsung
ether4 — Mediaplayer Dune
ether5 — свободен

На Синолоджи поднят веб-сервер (порты 80, 443), доступ из локальной сети в веб-серверу есть, все работает.
В службе DDNS Synology зарегистровано имя и присвоен адрес myname.synology.me

Что нужно:
Получить доступ к веб-серверу из Интернет.

Что сделано:
1. Изучена процедура проброса портов в микротике.
2. Порт 80 проброшен на локальный адрес 192.168.88.150
/ip firewall nat
add action=masquerade chain=srcnat comment=»defconf: masquerade» out-interface=
ether1
add action=dst-nat chain=dstnat dst-port=80 in-interface=ether1 protocol=tcp
to-addresses=192.168.88.150 to-ports=80
3. Вот настройки файервола (там все по умолчанию, кроме третьей записи — это я пытался разрешить форвард на 80 порт , так как это не помогло, правило отключено )
/ip firewall filter
add action=accept chain=input comment=»defconf: accept ICMP» protocol=icmp
add action=accept chain=input comment=»defconf: accept established,related»
connection-state=established,related
add action=accept chain=forward disabled=yes dst-address=192.168.88.150
dst-port=80 in-interface=ether1 protocol=tcp
add action=drop chain=input comment=»defconf: drop all from WAN» in-interface=
ether1
add action=fasttrack-connection chain=forward comment=»defconf: fasttrack»
connection-state=established,related
add action=accept chain=forward comment=»defconf: accept established,related»
connection-state=established,related
add action=drop chain=forward comment=»defconf: drop invalid» connection-state=
invalid
add action=drop chain=forward comment=
«defconf: drop all from WAN not DSTNATed» connection-nat-state=!dstnat
connection-state=new in-interface=ether1
4. То что на 80 порту в микротике висит веб интефейс роутера знаю (см. ниже мои экспериметы)

Предпринятые попытки и результаты:
1. Если ничего трогать — при введении myname.synology.me попадаю на веб морду микротика.
2. Если отключаю сервис www или меняю его порт с 80 на другой — страница не доступна.
3. В файерволе отключал и удалял все правила — результат тот же.

Что-то мне подсказывает, что в файерволе надо что-то прописать.

Делаем свое сетевое хранилище c Synology DSM

На мой взгляд, одни из лучших NAS — это Synology. И по большей степени это благодаря их софту Synology DSM . Чтобы поставить эту ОС на любое x86 железо существует проект Xpenology.

Себе я сделал NAS на Synology DSM из старенького Intel NUC DE3815TYBE c 4 GB ОЗУ DDR3L Kingston KVR16LS11/4 и SSD Kingston A400 на 120 GB для установки ОС. Так же есть возможность установить ОС на HDD, предназначенный для хранения данных, но я решил выделить для этого отдельный SSD.

Итак, весь комплект:

Intel NUC DE3815TYBE — 1000 руб. на авито
ОЗУ Kingston KVR16LS11/4 DDR3L 4 GB — 1300 руб.
Kingston A400 120 GB — 1600 руб.
Плата Mini PCI-E PCI Express to SATA 3.0 — 440 руб.
USB флешка на 8GB — была в наличии
HDD Toshiba 2.5 на 2 TB — был в наличии
БП для NUC — был в наличии

На usb флешку ставится загрузчик, и она всегда должна быть вставлена в nuc.

Итак, приступим. Скачиваем образ IMG для флешки.

Образы всегда будут доступны тут, и всегда свежие: https://xpenology.com/forum/topic/7848-links-to-loaders/

Я пробовал образы, начиная с самых последних и шел ниже по списку, и все отказывались грузиться после установки DSM на моем NUC. Заработал образ DS3615xs 6.1 Jun’s Mod V1.02b.img, скачанный по этой ссылке

Теперь скачанный образ нужно отредактировать под параметры нашей флешки. Для этого распаковываем его и открываем файл DS3615xs 6.1 Jun’s Mod V1.02b.img через программу OSFMount. Ее можно скачать тут

Жмем Mount new:

И выбираем synoboot.img. Жмем Next:

На следующем шаге выбираем раздел на 15 МБ и жмем Next:

Далее убираем галочку с Read-only drive и жмем Mount:

Будет смонтирован новый раздел:

Теперь нам нужно отредактировать файл grub.cfg в каталоге grub. Но перед этим нужно узнать VID и PID флешки, которая будет загрузочной. Для этого я использовал программу ChipGenius, скачать можно тут.

Находим нашу флешку и жмем на нее. В нижнем окошке выйдет информация, включающая VID и PID:

Теперь в смонтированном разделе открываем grub.cfg в каталоге grub через Notepad++ (скачать можно тут) и меняем строки

на значения vid и pid своей флешки:

Сохраняем grub.cfg и размонтируем образ:

Теперь нужно записать отредактированный образ DS3615xs 6.1 Jun’s Mod V1.02b.img на флешку с помощью Rufus. Скачать можно тут

Просто выбираем в руфусе нужную флешку, затем образ DS3615xs 6.1 Jun’s Mod V1.02b.img и жмем Старт:

После успешной записи образа вставляем эту флешку в NUC и включаем его. На экране появится загрузчик и автоматически запустится первый пункт.

И после этого выйдет вот такая надпись:

Скрины загрузчика не мои, взял с xpenology.com

Теперь нужно зайти на http://find.synology.com/ чтобы найти наш nuc

Жмем подключиться и соглашаемся с лицензионным соглашением:

Далее нам будет предложено установить операционную систему. Жмем Установить:

На следующем этапе я нажал Установка вручную:

И выбрал файл DSM_DS3615xs_15284.pat, скачанный отсюда

Жмем зеленую кнопку Установить прямо сейчас, нас предупредят о форматировании подключенного накопителя:

И начнется установка DSM:

После установки устройство будет перезагружено и пойдет обратный отсчет 10 минут:

Где-то на 7 минуте у меня открылось окно с предложением создать учетную запись администратора. Создаем:

На следующем этапе вышло предложение настроить Автоматическое обновление и расписание проверок жестких дисков. Я выбрал ручное обновление, так как с новой версией DSM, с большой долей вероятности, наш NAS окирпичится без нужной версии загрузчика:

Далее нас просят настроить QuickConnect для удаленного доступа через сервера Synology. Для этого нужно прописать серийный номер и mac от реального Synology Diskstation в grub.cfg. Я нажал Пропустить этот шаг:

И после система скажет, что все настроено:

И будет открыт рабочий стол DSM:

Первым делом я добавил репозиторий с дополнениями от сообщества: https://synocommunity.com/

Для этого переходим в Центр Пакетов > Настройки > Источники пакетов и жмем Добавить, введя название и адрес репозитория http://packages.synocommunity.com/:

После добавления будет доступен весь список кастомных дополнений, включая Transmission:

Но чтобы установить какой-либо аддон, нужно смонтировать свободный раздел диска. Я был немного удивлен, когда зайдя в Диспетчер хранения > Разделы кнопка создать была неактивна. Хотя на моем SSD еще свободно около 100 ГБ. В общем, чтобы смонтировать раздел я зашел в Диспетчер хранения > RAID Group и создал как бы raid, но не raid, выбрав в типе raid Basic. И уже после этого во вкладке Разделы я смог добавить раздел на 100 ГБ.

Так же я поставил галочку на Запретить доступ к предыдущим версиям samba в Панель управления > Файловые службы > SMB и выключил ненужную мне службу bonjour

После этих манипуляций можно устанавливать нужные вам дополнения. Я установил Transmission через Центр пакетов > Сообщество и Monitorrent

Для Monitorrent нет пользовательского дополнения Synology, но зато есть докер контейнер на Docker Hub. А в Synology DSM есть дополнение Docker, позволяющее без особого труда установить вообще любые контейнеры.

Сначала нужно установить его через Центр пакетов:

Запустив, переходим в Реестр и ищем Monitorrent:

Официальный тот что снизу, от werwolfby. Во время установки был прописан порт контейнера Monitorrent 6687, я так же прописал его в поле Локальный порт и запустил. Перейдя по адресу DSM http://192.168.0.31:6687/ открылся Monitorrent:

Стандартный пароль monitorrent

Так же я установил Plex сервер через Центр пакетов и вручную обновил версию, так как на этой версии DSM Plex почему-то был версии 1.16, хотя доступна 1.18 и она без каких-либо проблем сейчас работает.

В итоге получилось отличное сетевое хранилище с моим собственным железом и с низким энергопотреблением.

В моем NUC только 1 sata порт, но есть разъем mini pci-e. Для установки HDD я заказал вот такую плату с 2 sata 3.0 и с чипом ASM1061 на всем известной площадке:

Пока что тестирую новый NAS с Synology DSM в ожидании этой платы, а основные функции сейчас выполняет мой D-Link DNS-320, о восстановлении которого я писал уже очень давно:

Он, кстати, иногда не запускает Transmission после перезагрузки. Приходится заходить на web ui и запускать вручную. В остальном же работает безотказно после того восстановления в 2016 году.

И напоследок, в Home Assistant легко добавить мониторинг состояния Synology DSM. Для этого в sensors.yaml:

В итоге имеем вот такую карточку для мониторинга:

Как раз SMART мониторинг состояния дисков через Home Assistant был для меня одной из главных особенностей в выборе ОС для своего NAS. Можно настроить простую автоматизацию на отправку уведомления при изменении статуса, чтобы быть в курсе, если диск будет пора менять.

Ссылка на основную публикацию
Adblock
detector